Contentstack – Azure NA – Service Disruption

Incident Report for Contentstack

Resolved

This incident has been fully resolved and all systems are operating normally. Thank you for your patience while we worked to restore the services.
Posted Mar 21, 2026 - 00:45 MDT

Monitoring

The issue affecting multiple services in the Microsoft Azure NA region has been mitigated and services are operating normally. Our team will continue monitoring system performance to ensure stability.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Mar 21, 2026 - 00:40 MDT

Update

Our engineering team continues to actively investigate the issue affecting multiple services in the Microsoft Azure NA region. Users may continue to experience service unavailability and API errors. We are working to identify the root cause and will provide another update as soon as more information becomes available.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Mar 21, 2026 - 00:10 MDT

Investigating

We are currently investigating a outage affecting multiple services in the Microsoft Azure NA region. During this time, users may experience service unavailability and API errors. Our engineering team has been mobilized and is actively working to identify the root cause and restore normal service.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Mar 20, 2026 - 23:24 MDT
This incident affected: Microsoft Azure US Region (Content Management API, Content Delivery API, Image Delivery API, GraphQL Delivery API, Assets API, Marketplace - Web Application, Marketplace - Installed Apps, Personalize - Web Application, Personalize - Management API, Launch - Web Application, Launch - Management API, Automation UI, Automation API, BrandKit UI, BrandKit API).