Contentstack – GCP NA – Publishing Failures

Incident Report for Contentstack

Resolved

This incident affecting content publishing in the GCP NA region has been fully resolved and all systems are operating normally.

Customer Action: No action is required from customers at this time.

We appreciate your patience while we worked to restore service.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 13, 2026 - 03:57 MDT

Monitoring

The issue affecting content publishing in the GCP NA region has been mitigated and services are operating normally. Our team will continue monitoring system performance closely to ensure stability.

Customer Action: No action is required from customers at this time.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 13, 2026 - 03:54 MDT

Investigating

We are currently investigating an issue affecting content publishing in the GCP NA region. During this time, users may experience failures when attempting to publish content. All other services remains unaffected.

Our engineering team has been mobilized and is actively working to identify the root cause and restore normal service.

Customer Action: No action is required from customers at this time.

We will share our next update as soon as we have more information

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 13, 2026 - 03:50 MDT
This incident affected: Google Cloud Platform US Region (Content Management API).