Contentstack Launch - All Regions - Edge Function

Incident Report for Contentstack

Resolved

This incident has been resolved.
Posted May 27, 2025 - 14:31 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2025 - 14:29 MDT

Update

We are still investigating this issue and will provide an update as soon as more information becomes available.
Posted May 27, 2025 - 10:33 MDT

Update

We have identified the issue and are still investigating this issue and will provide an update as soon as more information becomes available.
Posted May 27, 2025 - 09:14 MDT

Identified

We're currently experiencing an issue with Launch Edge Functions deployments. If your latest deployment shows "FAILED" status and your project contains Launch Edge Functions, please do not attempt to redeploy until further notice. Redeploying under these conditions could potentially disrupt your live website functionality. Our team is actively working to resolve this issue, and we appreciate your patience during this time. If your latest deployment is not in a "FAILED" state, then no issue is expected.
Posted May 27, 2025 - 07:43 MDT
This incident affected: Amazon Web Services US Region (Launch - Edge Services), Amazon Web Services EU Region (Launch - Edge Services), Microsoft Azure US Region (Launch - Edge Services), Microsoft Azure EU Region (Launch - Edge Services), Google Cloud Platform US Region (Launch - Edge Services), and Google Cloud Platform EU Region (Launch - Edge Services).