Verification is currently underway for the maintenance items.
Posted Jan 17, 2026 - 01:23 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 16, 2026 - 22:30 MST
Scheduled
Please be advised that on January 17, 2025, the Contentstack team will conduct scheduled maintenance on the Azure NA and EU production Elasticsearch clusters. No service downtime is expected during this activity.
Start: January 17, 2025, at 05:30 UTC End: January 17, 2025, at 09:30 UTC Duration: 4 hours Expected Downtime: None
Impact: Customers hosted in the Azure NA and EU regions may experience temporary performance degradation during the maintenance window.
If you encounter any issues during or after the maintenance window, please contact Contentstack Support.
Posted Jan 13, 2026 - 07:41 MST
This scheduled maintenance affected: Microsoft Azure US Region (Web Application, Content Management API) and Microsoft Azure EU Region (Web Application, Content Management API).