Contentstack – GCP NA – Publishing Delays

Incident Report for Contentstack

Resolved

The intermittent delays affecting content publishing on GCP NA have been resolved. The fix applied by our engineering team has stabilized publishing performance, and we have confirmed normal operation through continued monitoring. All other components remained unaffected throughout this incident.


No action is required from customers at this time.


If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 12, 2026 - 04:30 MDT

Monitoring

Our engineering team has applied a fix for the intermittent delays affecting content publishing on GCP NA and we are monitoring the results.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 12, 2026 - 04:24 MDT

Identified

We identified the cause of intermittent delays when publishing content on GCP NA. Our engineering team is working on a fix. All other components remain unaffected.

No action is required from customers at this time.
If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 12, 2026 - 04:20 MDT

Investigating

On July 12 at 10:00 UTC, we began experiencing intermittent delays when publishing content on GCP NA. Users may notice publish requests taking longer than usual to complete. All other components remains unaffected.

No action is required from customers at this time. We will share our next update as soon as we have more information.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 12, 2026 - 04:13 MDT
This incident affected: Google Cloud Platform US Region (Content Delivery API).