This incident has been resolved. If you are still experiencing any issues, please redeploy your application or contact our Customer Support for assistance.
Posted Feb 12, 2026 - 04:57 MST
Monitoring
A fix is being applied, and we are actively monitoring the situation.
If you still face a timeout, affected customers are requested to redeploy their applications to ensure full restoration of service.
Posted Feb 12, 2026 - 04:35 MST
Identified
Customers in the Azure NA region may experience timeouts when accessing applications deployed on Launch, which may impact existing deployments.
Our team is actively investigating the issue and working toward a resolution. We are closely monitoring the situation and will provide updates as more information becomes available.
If you experience any issues accessing our services, please contact our Customer Success team for assistance.
Posted Feb 12, 2026 - 04:03 MST
This incident affected: Microsoft Azure US Region (Launch - Content Delivery Network (CDN)).