Earlier today, there was an unexpected period of downtime with our Contentstack platform.
Around 2 PM ET, we experienced an upstream outage that affected our Launch service.
This stemmed from technical issues with our CDN provider (Cloudflare), a service we rely on for speed and reliability. We know this disruption was likely very frustrating to you, as it was to us.
Cloudflare service full availability took 3 hours 12 minutes to return, and Contentstack Launch service was fully restored immediately. Although it's rare to see major services go down, it did happen this time - and we're continuing to attempt to learn more about what happened here (as are many other Cloudflare customers).
Thank you for your patience and continued trust. We will review our system to improve the reliability of our CDN provider. We’re committed to delivering the dependable, enterprise-grade experience you expect. If you have any concerns or feedback, we are here to help.
Posted Jun 12, 2025 - 15:35 MDT
Update
Launch sites have been fully recovered as services have resumed from Cloudflare.
We are closely monitoring the situation and will share updates as it progresses.
Posted Jun 12, 2025 - 15:10 MDT
Monitoring
Cloudflare services have begun to recover, and Launch sites appear to be gradually coming back online.
Cloudflare is actively working to fully restore stability. We’re closely monitoring the situation and will share updates as things progress.
Posted Jun 12, 2025 - 14:20 MDT
Update
Our team is actively monitoring the state of the Cloudflare Outage.
We will continue to provide updates as more information becomes available.
Please be informed that sites hosted on Contentstack Launch are currently experiencing 500 errors due to an ongoing Cloudflare outage. Our CDN provider is currently experiencing an issue that may be impacting site performance or availability.
Our team is actively working with Cloudflare to expedite resolution. We appreciate your understanding and patience during this time.
For any urgent concerns, please don’t hesitate to contact our Customer Success Team.
Posted Jun 12, 2025 - 12:38 MDT
This incident affected: Amazon Web Services US Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services), Amazon Web Services EU Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services), Microsoft Azure US Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services), Microsoft Azure EU Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services), Google Cloud Platform US Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services), and Google Cloud Platform EU Region (Launch - Web Application, Launch - Management API, Launch - Content Delivery Network (CDN), Launch - Edge Services).