This incident affecting the delivery of newly published content in the GCP NA region has been fully resolved and all systems are operating normally.
Recently published and unpublished changes are being reflected in delivered content as expected. Delivery of already-published content continued to function normally throughout.
We appreciate your patience while we worked to restore service.
If you encounter any difficulties accessing our services,
Posted Sep 19, 2026 - 22:35 MDT
Monitoring
The issue affecting the delivery of newly published content in the GCP NA region has been mitigated and services are operating normally. Recently published and unpublished changes are being reflected in delivered content as expected. Our team will continue monitoring system performance closely to ensure stability.
If you encounter any difficulties accessing our services, please reach out to our Contentstack Support for assistance at support@contentstack.com.
Posted Sep 19, 2026 - 22:30 MDT
Identified
The root cause of the issue affecting the delivery of newly published content in the GCP NA region has been identified. Our engineering team is currently implementing a fix to restore normal service.
During this time, recently published or unpublished content may take longer than usual to appear in delivered content, including through GraphQL queries and asset URLs. Content delivery of already-published content remains unaffected. Other regions remain unaffected.
Customer Action: No action is required from customers at this time.
We will share our next update as soon as we have more information.
Posted Sep 19, 2026 - 22:18 MDT
Investigating
we began investigating an issue affecting the delivery of newly published content in the GCP NA region. During this time, recently published or unpublished content may take longer than usual to appear in delivered content, including through GraphQL queries and asset URLs. Content delivery of already-published content remains unaffected. Other regions remain unaffected.
Our engineering team has been mobilized and is actively working to identify the root cause and restore normal service.
Customer Action: No action is required from customers at this time.
We will share our next update as soon as we have more information.
If you encounter any difficulties accessing our services, please reach out to our Contentstack Support for assistance at support@contentstack.com.
Posted Sep 19, 2026 - 21:31 MDT
This incident affected: Google Cloud Platform US Region (Content Delivery API, GraphQL Delivery API, Assets API).