This incident has been resolved. The fix has been deployed, and our Automate service is now operating normally. All automations are processing without delay. We apologize for any inconvenience this may have caused.
Posted Sep 04, 2025 - 00:29 MDT
Identified
We have identified the root cause of the degradation affecting our Automate service in the AWS North America region. Our team is now implementing a fix. We will provide another update shortly.
Posted Sep 03, 2025 - 23:29 MDT
Investigating
We are currently experiencing a service degradation in our AWS North America region for Automate. Customers may encounter delays when executing automations. Our team is investigating the issue.If you encounter any problems while accessing our services, please do not hesitate to contact our Customer Success Team.
Posted Sep 03, 2025 - 22:55 MDT
This incident affected: Amazon Web Services US Region (Automation API).