Contentstack - AWS EU - Webhook Issue

Incident Report for Contentstack

Resolved

This incident affecting the Webhook Dispatcher in the Amazon Web Services EU Region has been fully resolved and all systems are operating normally.
No action is required from customers at this time.
We appreciate your patience while we worked to restore service.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jun 26, 2026 - 07:35 MDT

Monitoring

The issue affecting the Webhook Dispatcher in the Amazon Web Services EU Region has been mitigated and services are operating normally. Our team will continue monitoring system performance closely to ensure stability.
Customer Action: No action is required from customers at this time.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jun 26, 2026 - 07:30 MDT

Identified

The root cause of the issue affecting the Webhook Dispatcher in the Amazon Web Services EU Region has been identified. Our engineering team is currently implementing a fix to restore normal service. Other regions and core content management and delivery services remain unaffected.
Customer Action: No action is required from customers at this time.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jun 26, 2026 - 07:17 MDT

Investigating

We are currently investigating an issue affecting the Webhook Dispatcher in the Amazon Web Services EU Region. During this time, users may experience delays or failures in webhook delivery. Other regions and all other Contentstack services remain unaffected.
Our engineering team has been mobilized and is actively working to identify the root cause and restore normal service.

Customer Action: No action is required from customers at this time. If your integration depends on webhook events, you may wish to monitor your endpoint logs for any missed deliveries.
We will share our next update as soon as more information is available.

If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jun 26, 2026 - 07:01 MDT
This incident affected: Amazon Web Services EU Region (Webhook Dispatcher).