Verification is currently underway for the maintenance items.
Posted Jan 10, 2026 - 01:43 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 09, 2026 - 22:30 MST
Scheduled
Please be advised that on January 10, 2025, the Contentstack team will conduct scheduled maintenance on the GCP NA and EU production Elasticsearch clusters. No service downtime is expected during this activity.
Start: January 10, 2025, at 05:30 UTC End: January 10, 2025, at 09:30 UTC Duration: 4 hours Expected Downtime: None
Impact: Customers hosted on GCP NA and EU regions may experience temporary performance degradation during the maintenance window. If you encounter any issues while accessing the platform, please reach out to our Customer Success team for assistance.
For any concerns or if issues persist beyond the maintenance window, please contact Contentstack Support.
Posted Jan 09, 2026 - 07:50 MST
This scheduled maintenance affected: Google Cloud Platform US Region (Web Application, Content Management API) and Google Cloud Platform EU Region (Web Application, Content Management API).