The upstream cloud provider issue affecting the Microsoft Azure NA region is still ongoing, with recovery continuing on the provider's side. Contentstack services remain fully operational, and we have not observed any impact to content management or content delivery at any point during this event.
Our engineering team continues to actively monitor the situation and remains ready to respond immediately should any impact to our services arise.
Customer Action: No action is required from customers at this time.
We will share our next update within 60 minutes, or sooner if the situation changes.
If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted May 29, 2026 - 04:11 MDT
Update
The upstream cloud provider issue affecting the Microsoft Azure NA region remains ongoing, with recovery still in progress on the provider's side. Contentstack services continue to operate normally, and we have not observed any impact to content management or content delivery at any point.
Our engineering team remains actively engaged and is continuing to monitor the situation closely, ready to act immediately should any impact to our services arise.
Customer Action: No action is required from customers at this time.
We will share our next update within 60 minutes, or sooner if the situation changes. If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted May 29, 2026 - 02:34 MDT
Identified
We are aware of an ongoing issue with our upstream cloud provider affecting the Microsoft Azure NA region. At this time, we have not observed any impact to Contentstack services, and all systems — including content management and content delivery — are operating normally.
As a precaution, our engineering team is proactively monitoring the situation closely and is prepared to act immediately should any impact to our services arise. We are posting this update in the interest of transparency so you are informed while we keep watch.
Customer Action: No action is required from customers at this time.
We will share our next update within 60 minutes, or sooner if the situation changes. If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted May 29, 2026 - 01:31 MDT
This incident affected: Microsoft Azure US Region (Web Application, Content Management API, Content Delivery API).