The issue has been mitigated and services are operating normally. Thank you for your patience.
Posted Aug 29, 2025 - 10:14 MDT
Monitoring
The recent incident has been mitigated, and all operations have returned to normal. Our team will continue to closely monitor the situation to ensure ongoing stability and performance. Thank you for your patience and support.
Posted Aug 29, 2025 - 10:01 MDT
Investigating
We are currently experiencing an incident that is impacting the availability and performance of our Launch - AWS NA - Delivery service. Our engineering and security teams are actively working to mitigate the attack and restore normal operations as quickly as possible. You may experience slow loading times, intermittent connectivity, or temporary unavailability during this period. We will provide updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Aug 29, 2025 - 09:48 MDT
This incident affected: Amazon Web Services US Region (Launch - Content Delivery Network (CDN)).