A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 16:51 MDT
Identified
The issue affecting the Contentstack Web Application in the Microsoft Azure NA and Azure EU regions has been identified. Our engineering team is currently implementing a fix to restore normal access. This issue is limited to the web application interface — the Content Management API, content delivery of published content, and other services continue to operate normally.
Customer Action: No action is required from customers at this time. Customers who need to manage content in the interim can continue to do so via the Content Management API.
If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 23, 2026 - 16:35 MDT
Investigating
We are currently investigating an issue affecting the Contentstack Web Application in the Microsoft Azure NA and Azure EU regions. During this time, users may successfully log in but find that the dashboard (application homepage) fails to load. This issue is limited to the web application interface the Content Management API, content delivery of published content, and other services continue to operate normally.
Our engineering team has been mobilized and is actively working to identify the root cause and restore full access to the web application. We understand the inconvenience this may cause and are treating it with high priority.
Customer Action: No action is required from customers at this time. Customers who need to manage content in the interim can continue to do so via the Content Management API.
If you encounter any difficulties accessing our services, please reach out to our Customer Success team for assistance at support@contentstack.com.
Posted Jul 23, 2026 - 16:05 MDT
This incident affected: Microsoft Azure US Region (Web Application) and Microsoft Azure EU Region (Web Application).